Solucionar problemas de sonido en Hardy

Muchos de nosotr@s hemos sufrido en nuestras propias carnes, la perdida del sonido cuando ejecutabamos alguna aplicacion en Ubuntu Hardy Heron. Parece que la explicacion al problema es la siguiente:

En Ubuntu 8.04 se decidio usar Pulse Audio como servidor de audio para reproducir el mismo. En principio todas las aplicaciones y librerias deberian utilizarlo pero esto no es asi, y hay muchas aplicaciones que todavia no han podido actualizarse y dan problemas a la hora de emplear Pulse Audio. Para solucionarlo se creo un driver para “ALSA” llamado “Pulse” que se encargara de redireccionar a Pulse Audio todas esas llamadas de las aplicaciones que aun no lo soportan. El problema se da en esas aplicaciones que hacen uso de ALSA de una forma especial. Para solucionarlo podemos hacer lo siguiente.
Vamos a Sistema > Preferencias > Sonido y en la pestaña dispositivos, seleccionamos en el combo text “Pulse Audio Sound Server” para todos los casos.

En la pestaña “Sonidos” habilitamos la opcion “Activar mezcla de sonidos por hardware (ESD)”
y ahora reiniciamos el sistema de sonido:

Desde consola, ejecutamos:

$ sudo /etc/init.d/pulseaudio restart

Ahora todo, deberia “oirse” bien… (espero)

Toda esta informacion esta mas completa en el enlace original, te recomiendo que lo leas:

Enlace | Biestado

11 Responses to “Solucionar problemas de sonido en Hardy”


  1. 1 Salomón mayo 30, 2008 en 9:10 pm

    Gracias! me ayudo mucho!!, me soluciono el problema de crossfading en amarok (cada transición de canción era insoportable) pero ahora 0 problemas! :)

  2. 2 Salomón mayo 30, 2008 en 11:50 pm

    Todo a la perfección… excepto que me deja sin sonido los videos de youtube :(… xq sera?

  3. 3 raton mayo 31, 2008 en 5:38 pm

    Funciona de maravilla. Gracias

  4. 4 kraptor junio 2, 2008 en 7:43 am

    Salomón: En el post original está también la solución para el problema de audio de flash ;)

  5. 5 Bostero_23@hotmail.com septiembre 4, 2008 en 8:37 pm

    muy bueno loco, muy muy bueno. Gracias che. Busque por todos lados y no tenia solucion a lo del sonido. un abrazo che

  6. 6 cristian octubre 7, 2008 en 3:39 am

    hice lo que indica este post y nada sigo sin que el rithmbox me reproduzca el audio, encima cuando cliqueo sobre una track este no se ejecuta y pasa de uno a otro rapidamente sin reproducir nada

  7. 7 Logan octubre 24, 2008 en 1:53 pm

    Ni te imaginas lo que lecie editando archivos y todo eso, como con el ubuntu gutsy.

    Gracias.

  8. 8 filix diciembre 24, 2008 en 10:55 pm

    Hola, este es mi primer post pidiendo ayuda sobre ubuntu, hasta ahora todo parecia ir bien, pero aqui me quedo bloqueado, mi problema es el siguiente:

    No puedo ejecutar aplicaciones conjuntas de archivos de audio de musica como totem y rhythmbox junto con alguna aplicacion java como pueda ser juegos y demas, la aplicacion que antes coja el audio esa lo reproducira, dejando a la otra sin sonido, y viceversa, o sea no puedo combinar sonidos de estas caracteristicas.

    He probado todo lo que he encontrado, pero en tu explicación no puedo reiniciar el sistema de sonido, me dice que no encuentra la orden.

    Espero encontrar la solución, aunque una ayudita se agradeceria mucho.

  9. 9 jdanielgb noviembre 27, 2009 en 4:35 am

    solucion Definitiva !!!

    Mire, yo tube eso y más problemas con el sonido, lo que pasa es que en ubuntu, estas nuevas versiones trae incorporado el servidor de sonido Pulseaudio, y en realidad ese servidor es muy comflictivo con muchos programas, aqui te presento la opcion de reinstalar todo el servidor de alsa y hacer que los programas no se vean obligados a usar Pulse audio, solo sigue estas instrucciones:

    Primero arreglaremos el problema con ALSA, para lo que reconstruiremos de forma simple y automatizada este modulo, ya que haciéndolo manual se pierde un poco la limpieza de nuestra instalación:

    sudo apt-get install module-assistant

    sudo m-a a-i alsa

    sudo m-a update

    sudo m-a prepare

    Este ultimo paso tomara mas tiempo que los anteriores y veremos algo como esto en nuestra consola:

    Reiniciamos para no meternos manualmente con modprobe/rmmod.

    Ahora, para evita que las aplicaciones pasen por PulseAudio, iremos a Sistema > Preferencias > Sonido y seleccionaremos todas las opciones a que utilicen ALSA, deberia de quedar algo así:

    Si queremos, al seleccionar cada opción, podemos presionar el botón de “Probar” para asegurarnos que todo anda bien.

  10. 10 fideox junio 13, 2010 en 11:19 pm

    Gracias, me sirvió el comentario de jdanielgb con lo que dice en su comentario pude solucionar mi problema.
    Gracias.


  1. 1 Con mis movidas… y mis lios » Blog Archive » Bugs en Ubuntu Hardy Trackback en junio 1, 2008 en 2:21 pm

Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s





The next version of Ubuntu is coming soon


¿Es compatible tu equipo con Ubuntu?


( Muchos fondos de pantalla, aqui )

DESCARGATE SCIFI LIFE

365 Dias de Soledad
Me debes los sueños, las promesas y las noches rotas. Me debes la paz, la sonrisa y la esperanza robadas. Me debes la sangre, las lágrimas y el sudor vertido. Me debes las noches vacías, los abrazos anhelados. Me debes un beso de ajenjo de tu amarga boca.

The Ubuntu Counter Project - user number # 11961
Geo Visitors Map
mayo 2008
L M X J V S D
« abr   jun »
 1234
567891011
12131415161718
19202122232425
262728293031  

Blog Stats

  • 26,580,788 hits

Seguir

Recibe cada nueva publicación en tu buzón de correo electrónico.

Únete a otros 1.032 seguidores

%d personas les gusta esto: