SMPlayer se para cuando reproduzco video, Solucionado

Un lector me acaba de escribir referenciando este post que escribi hace unos dias.
El problema es que SMPlayer se pausa, no reproduce el video, y seguramente este error sea un problema con el sonido.
Cuando tengais problemas de este tipo y no sepais muy bien lo que pasa, le tenemos que preguntar al sistema. ¿Como?
me diras….
Pues podemos preguntar al sistema de 2 formas:

1) Ejecutando la aplicacion desde consola. Entonces, si hay errores se suelen mostrar por consola.

2) Mirando los logs del Sistema. Nos vamos a Sistema > Administracion > Sucesos del Sistema y mirando el log del demonio syslog seguramente veamos lo que pasa.

Imaginemos hipoteticamente que has abierto SMPlayer para intentar ver un video y no te lo reproduce. Entonces miramos el log y vemos que tal vez tenemos esta linea:

Error opening PCM Device: Dispositivo o recurso ocupado

mmm, parece que tenemos el sistema de audio pillado por otro proceso o bloqueado.
Esto parece un problema de Pulse Audio.

Ya os comente hace unos dias que en Ubuntu 8.04 se estaba usando como servidor de audio Pulse Audio, pero «no todas las aplicaciones estaban preparadas para usar Pulse Audio».
Ese parece ser el problema en este caso.

Tendriamos que irnos a preferencias de SMPlayer Opciones > Prefencias y cambiar el combo de texto,
sustituyendo «Pulse» por «Alsa» que es el medio de sonido que se empleaba anteriormente.
Reinicias SMPlayer y seguramente ya puedas ver ese video.

Esto mismo seguramente lo tienes que hacer en otras aplicaciones de audio que estes usando por ejemplo en Mplayer. Tambien en Preferences > Audio

(Bueno Pablo, suerte, a ver si tu problema era este)

Relacionado | Solucionar problemas de sonido en Hardy

8 Respuestas to “SMPlayer se para cuando reproduzco video, Solucionado”


  1. 1 linuxeate junio 4, 2008 a las 9:47 pm

    Muchas gracias, si se soluciono ese problema que tenia XD.

  2. 2 Anfet junio 7, 2008 a las 2:14 pm

    q mas superpiwi, a mi me a votado el sigiente error,

    /usr/bin/mplayer -noquiet -nofs -sub-fuzziness 1 -identify -slave -vo x11 -ao alsa -zoom -nokeepaspect -framedrop -input conf=/usr/share/smplayer/input.conf -stop-xscreensaver -wid 41943052 -monitorpixelaspect 1 -subfont-autoscale 1 -subfont-text-scale 5 -subcp ISO-8859-1 -subpos 100 -contrast 0 -brightness 0 -hue 0 -saturation 0 -nocache -osdlevel 0 -vf-add screenshot -channels 2 -af scaletempo /media/Datos/anfet/mi pc/Videos/movies/Rapido y furiosos reto tokyo]/Rapido.y.furiosos.reto.en.tokyo.DVDRiP.Xvid.Spanish.Latino.[www.LatinoDivx.com].avi

    MPlayer dev-SVN-r25315
    CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 3800+ (Family: 15, Model: 75, Stepping: 2)
    CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
    Compiled with runtime CPU detection.
    Can’t open joystick device /dev/input/js0: No such file or directory
    Can’t init input joystick
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support. You will not be able to use your remote control.
    Terminal type `unknown’ is not defined.

    Playing /media/Datos/anfet/mi pc/Videos/movies/Rapido y furiosos reto tokyo]/Rapido.y.furiosos.reto.en.tokyo.DVDRiP.Xvid.Spanish.Latino.[www.LatinoDivx.com].avi.
    AVI file format detected.
    ID_VIDEO_ID=0
    [aviheader] Video stream found, -vid 0
    ID_AUDIO_ID=1
    [aviheader] Audio stream found, -aid 1
    VIDEO: [XVID] 512×384 12bpp 23.976 fps 811.6 kbps (99.1 kbyte/s)
    Clip info:
    Software: VirtualDubMod 1.5.10.2 (build 2540/release)
    ID_CLIP_INFO_NAME0=Software
    ID_CLIP_INFO_VALUE0=VirtualDubMod 1.5.10.2 (build 2540/release)
    ID_CLIP_INFO_N=1
    ID_FILENAME=/media/Datos/anfet/mi pc/Videos/movies/Rapido y furiosos reto tokyo]/Rapido.y.furiosos.reto.en.tokyo.DVDRiP.Xvid.Spanish.Latino.[www.LatinoDivx.com].avi
    ID_DEMUXER=avi
    ID_VIDEO_FORMAT=XVID
    ID_VIDEO_BITRATE=811648
    ID_VIDEO_WIDTH=512
    ID_VIDEO_HEIGHT=384
    ID_VIDEO_FPS=23.976
    ID_VIDEO_ASPECT=0.0000
    ID_AUDIO_FORMAT=85
    ID_AUDIO_BITRATE=128000
    ID_AUDIO_RATE=0
    ID_AUDIO_NCH=0
    ID_LENGTH=6254.75
    xscreensaver_disable: Could not find XScreenSaver window.
    Opening video filter: [screenshot]

    MPlayer interrupted by signal 11 in module: init_video_filters
    ID_SIGNAL=11
    – MPlayer crashed by bad usage of CPU/FPU/RAM.
    Recompile MPlayer with –enable-debug and make a ‘gdb’ backtrace and
    disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
    – MPlayer crashed. This shouldn’t happen.
    It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
    gcc version. If you think it’s MPlayer’s fault, please read
    DOCS/HTML/en/bugreports.html and follow the instructions there. We can’t and
    won’t help unless you provide this information when reporting a possible bug.

    q podria ser ???

  3. 3 superpiwi junio 7, 2008 a las 2:52 pm

    Mal tema
    me quedo con la ultima parte:

    – MPlayer crashed by bad usage of CPU/FPU/RAM.
    Recompile MPlayer with –enable-debug and make a ‘gdb’ backtrace and
    disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
    – MPlayer crashed. This shouldn’t happen.
    It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
    gcc version

    Dice que ha hecho crash por un mal uso de CPU/FPU o RAM.
    que puede ser un bug en el codigo de MPlayer, en tus drivers, o en la version de gcc.

    Te proponen que lo recompiles con la opcion -enable-debug para obtener mas informacion.

    Lo dicho, algun problema que no se sabe muy bien a que es debido.
    Pudiera ser un tema de codecs.
    Te da problemas en todos los videos???

  4. 4 Anfet junio 8, 2008 a las 5:09 pm

    No, con totem y xine abren perfectamente, con smplayer me da ese error, lo raro del caso es con vlc, con el cual deveria reproducir cualquier archivo solo me abre el audio.

    pstt: gracias por la atencion

  5. 5 rvm octubre 23, 2008 a las 12:38 am

    El problema puede ser debido a que quizás tienes un mplayer compilado sin soporte para png (necesario para el filtro screenshot).

    Una forma de solucionarlo sería desactivando las capturas de pantalla. Eso se puede hacer borrando el directorio para las capturas de pantalla en el diálogo de preferencias.

  6. 6 Jesús Abad marzo 30, 2009 a las 9:20 pm

    Yo tenía el mismo problema que Superpiwi y lo arreglé de forma parecida a lo de seleccionar en preferencias de audio «alsa» en lugar de «pulse» pero en el apartade de video, eligiendo «x11»

  7. 7 Víctor diciembre 28, 2009 a las 11:35 pm

    Y mi caso fue curioso, yo lo solucioné al revés, cambié alsa por pulse.

    Aunque llevo tiempo en Ubuntu no soy un experto, y mi caso quizá se debió a que instalé el editor de video Openshot y en aptitude me proponía remover varios paquetes que normalmente utilizaría (como el paquete ugly de gstreamer). Como me encontraba un poco cansado (me encontraba de manazas con mi pc, de hecho perdí todo el home) pues no le puse mucha atención y después sufrí para reproducir correctamente los videos en SMPlayer (mi reproductor favorito, salvo para los DVD’s, para eso uso el VLC).

    El reproductor se pausaba después de varias veces en que avanzaba en los clips con las flechas de desplazamiento. Busqué una posible solución y mira que me encontré este post (soy asiduo visitante del blog), solo que apliqué la solución inversa.


  1. 1 Algunas noticias | Paraíso Geek Trackback en junio 5, 2008 a las 4:29 pm

Deja una respuesta

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Salir /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Salir /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Salir /  Cambiar )

Conectando a %s







¿Es compatible tu equipo con Ubuntu?


( Muchos fondos de pantalla, aqui )

DESCARGATE SCIFI LIFE

365 Dias de Soledad
Me debes los sueños, las promesas y las noches rotas. Me debes la paz, la sonrisa y la esperanza robadas. Me debes la sangre, las lágrimas y el sudor vertido. Me debes las noches vacías, los abrazos anhelados. Me debes un beso de ajenjo de tu amarga boca.

The Ubuntu Counter Project - user number # 11961
Geo Visitors Map

Archivos

junio 2008
L M X J V S D
 1
2345678
9101112131415
16171819202122
23242526272829
30  

Blog Stats

  • 31.310.807 hits

A %d blogueros les gusta esto: